• Welcome to Jose's Read Only Forum 2023.

KNOPPIX; With or Without VM?

Started by Donald Darden, October 22, 2007, 11:57:46 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Donald Darden

I now have KNOPPIX with and without OpenVZ software.  You can find it and download it either way off the internet for free.  I also have Ubuntu 7.10 on CD, which is another distribution that is proving to be very popular.  Both distributions are very easy for Windows users to begin playing with, but the GNOME desktop with Ubuntu might be a bit friendlier for the casual PC user because it lists more games, and allows you to find more things a casual user might be interested in, whereas a serious PC person might find the development tools listed under the KDE desktop on KNOPPIX to be of greater interest.  But once you install either distribution, a lot of customization is possible.

Of course you don't have to install it; you can use the .ISO image you download and burn it to CD, then boot to it.  In fact that is the default way of using KNOPPIX.  If you want to actually install it to your hard drive, you boot to the CD, then after you get the live version up and running, you have to run a program called knoppix-installer to install it to a hard drive.  With Ubuntu, you get a menu choice, which is a bit easier.

How do you run knoppix-installer?  You get to a command shell, which you can do by holding down the Cltl (Control) and Alt (Alternate) keys at the same time and pressing F2, F2, F3, or F4, which will give you access to the bash shell for one of the four command shells associated with the four desktops allowed you.  And there is where you type in the bash command or name of a program to run.  In this case, just knoppix-installer.

Since KNOPPIX and Ubuntu are both based on the Debian version of Linux, they benefit from being updated in a similar manner using .DEB packages rather than the RPM packages.  However, you can find instructions and tools on the internet for converting between the two package systems, or for building your own packages.  So this is not a crucial distinction.

Donald Darden

Finding packages specific to Knoppix can be problematic.  I did learn that if you download an RPM package, kpackage will offer to install it.  I believe this traces back to earlier history, where Knoppix was set up to handle RPM packages primarily.  Now they say it uses Debian.  Of course you probably know that the program alien lets you work with either, and render either into the other.  If it works.  Options with alien even allow you to try and install it.  kpackage just makes the whole process more graphical.

Some packages are offered as TAR files with some type of compression.  In this case, binary files present special challenges, because they come pre-compiled, so either they work with our distribution -- or they don't.  The most common form of compression is probably gz, which stands for GNU zio format.  If you download a TAR.gz file with Knoppix, it will probably offer to open it with ark, which again gives you the graphical interface.  RPM or DEB packages specific to your distribution are probably the easiest and most fool proof method -- assuming whomever put the package together got it right.

Another choice is having the source code files offered in a TAR package.  If you get this package, you need to decompress or extract the contents and put them into a temporary folder, which you can make using the mkdir command.  However, ark will let you create a new folder for this purpose, much as you can with WinZip or WinRAR under Windows.  I wanted the newest version of WINE for Knoppix, and my reading says that it currently ships with Wine 0.9.12 on the CD.  The latest version from Wine HQ is 0.9.47.  My reading suggest that you should uninstall the old version and download and install the new.  But I could not find a DEB package for WINE, nor for
VMWare Server, another product I want to mess with.  I did try a RPM package that I found, but it failed because the location and name of the BASH shell is not the same between the Linux distributions.

I did find the source files for Wine 0.9.47, but not at Wine HQ, and not in a typical TAR.gz archive.  Rather, I found them in a TAR.bz2 file, and I had to research that.  It is a different compression method that apparently ark does not recognize, and it requires bzip2 to do the decompression.  Using a terminal console (see Konsole on the toolbar), I used the find command to see if Knoppix included bzip2.  In other words, I entered find bzip2, and it told me that it could not be found.  So I went back to the Internet and searched for bzip2, and found where I could download it.  And I got that as a source code archive in a TAR.gz file. So I used ark to create a folder and named it Wine (note that they suggest you capitalize the first letter of directories so as not to cause confusion with lower case file names).  Then I extracted its contents into that new folder, then I entered the terminal console mode, positioned to the new folder using the cd command, then I finally ran make, followed by make install, and it compiled and installed bzip2 onto my hard drive along with Knoppix.  I've onlly had time to see if it works by seeing if it would list the contents of the TAR.bz file to the stdout device.

Next thing is to remove the present version of WINE, then install the new version in its place.  That is usually safer than trying to maintain and use multiple versions of the same product on the same OS. 

Donald Darden

Boy, More and more things to find and issues to resolve.

1.  IT turns out that ark is actually able to decompress the TAR.bz2 files, so you do not need bzip2 as I had thought.  I tried it, it worked, so what more to say.

2.  Firefox is installed on Knoppix under the name iceweasel.  IT is a bit buggy, because it can't seem to maintain font size correctly from one link to another.  I get tired of using Ctrl with either - or + to control size, so I downloaded the Linux version of Firefox, deleted the contents of /etc/firefox, then extracted the downloaded contents into that same folder.  It seems to be working better now.  I read that they are likely to change the name iceweasel to icecat. 

3.  The terminal console always show folder names in blue, which I find hard to read against the black background.  You can change the color scheme, but I haven't figured out where you can alter the color or behavior regarding the use of colors for folders and certain types of files.  Every color scheme will make it hard to read at least the folder names or displayed file names.  I'd as soon just use a single color for everything.  You can use XTerm, but there is no color management control there, and they still want to colorize folder and filenames, making some hard to read.  A part of the problem is that terminal console emulation goes back several decades, and we are stuck with just 8 colors, intensity, and bold as options.  Anybody know of anything better?
                    I just answered my own question.  It turns out that you can look at the configuration for
                    your bash shell at /etc/bashrc.  There you will see that ls is turned into an alias of itself
                    with the statement:
                                alias ls="ls --color=auto

                    Your choices for ls --color are auto, always, or never.  You can modify the bashrc file to
                                alias ls="ls --color=never

                    Or you can type this in manually once in the terminal console mode.

                     There is also some way to set additional defaults when entering the bash shell on a per
                     user bases, but the method varies by Linux distribution.  I'm not sure how to do it for
                     Knoppix yet, but it is probably the same for all Debian distributions.

4.  If you use the K button at lower left, search for Control Center.  You can make some changes there,  In my case, the disktop is not centered or fully stretched,  So under Peripherals, I went to Display, then changed the display size and refresh rate.  A box controls whether to apply these settings at startup, so I checked it.  Then I applied the result.  You might still have to reposition the resulting screen on a CRT screen with the manual controls for that monitor.

5.  Apparently Knoppix does not come with all applications that are menu-ready included in the current menu listings.  You can use the K Menu button again at the lower left and go to Settings, then click on the Menu Updating Tool.  In my case, it found and added another 22 items to the menus.

Donald Darden

Olay, I've made a bit of progress, but hit a roadblock.  apt is mentioned as the primary way in which packages are downloaded, installed, and updated.  To download, install, and remove packages on a Debian distribution, the principle tool is apt-get.  But in reading some of the Debian literature, I found discussions about using aptitude, synaptic, dselect. or dpkg rather than apt-get direct.  And apt-get supports  dselect-upgrade as one of its options.  The impression I got was that aptitude is good, but once committed to it, it's value is in using it consistently, because it gives you the option to do rollbacks.  synaptic is suppose to be newer, but it really was not detailed in the source I found.  dselect and dpkg seem to be mentioned fairly frequently in posts, but by far there is more mentions regarding just using apt-get.

I tried using apt-get update, and some packages were updated.  Later I tried to use apt-get upgrade, and my PC went through a whole lot of replacement files (over 600).  Then I ran apt-get update again as suggested, and a few were replaced.  I reinstalled Wine with apt-get install wine, and a huge upgrade process then took place.  If you do this, add the -y parameter so you do not have to decide on yes or no to a number of prompts.

Trouble is, after all the dust had settled, I still have wine 0.9.12, which is pretty stale now, and my gcc version is 4.2.3.  Now the problem with this, is that in order to update wine to 0.9.48, which just came out, I have to download the source files (available from www.winehq.com and mirrors) and perform a ./configure command, which tries to recompile the source code.  Only the source code requires gcc to be at a version greater than 5.  And as I said, the version of gcc provided with Knoppix is at 4.2.3, and unable to compile and create the executables required.

So right now, the question is how I go about upgrading gcc to the current version, since apt-get upgrade failed to fetch it.  Or will someone bother to build a package specific to Knoppix 5.1?  Or will the release of Knoppix 5.2, when it comes out (some rumor of it exists) provide those necessary updates for us?

So as of this moment, for anyone interested in testing out Wine and seeing it it will let them run their favorite Windows applications, Ubuntu looks like the better choice.  This is because Ubuntu is being updated more often, and because Ubuntu is one of the distributions for which new Wine packages are being released routinely.

Meanwhile, anxious to give Wine a shot, I went ahead to see what I could do with it in terms of running PowerBasic apps.  I tried the 0.9.12 version with CCEdit.exe by first going to the proper folder (I used the graphical interface to maneuver there, and then under Tools on the menu I selected Open Terminal (or you can use the F4 key).  Then I entered wine CCEdit.exe, and there I was.

I also succeeded in running some compiled exe files from my earlier useage of PowerBasic.  So, in a sense, it works.  But not near as well as you would want it to.  See, the problem is, that for CCEdit to then run the compiler or debugger, it would have to make additional calls, but these would be fielded by the Linux system, not Wine or Windows, and those features would not work.  And if they don't work, then essentially you just end up with an editor that supports some syntax rules and does some other things.

What I would like to see perhaps is Wine as a shell, in which everything done by the windows application is intercepted and handled by it.  And made so that if you click on any file with a .EXE extension, the default opening application would be Wine.

Oh, incidently, if you use the terminal to call Wine and some windows or DOS executable, and it seems to hang, you can probably cancel Wine and the program by using Ctrl+Z.

One other possible use of Wine that has been suggested is to allow access to Windows drivers for scanners and printers.  Apparently this can be made to work, if windows is capable of recognizing the device.

Concerning the DVD distribution of Knoppix, the thread for Knoppix on DVD has been closed as of version 4.  I doubt that there is much help there.  Keep in mind that Knoppix seems to be the work of one individual. and some other distributions have whole communities of supporters to keep them current.

I'm not closing this thread, but for the present, I am going to install Ubuntu and carry on with it, just to see how feasable it will be to make more progress.
Meanwhile I continue to hope others are exploring some of the other alternatives and will eventually post their experiences as well.

Donald Darden

I decided that I might have been too hasty about my judgement call on Knoppix 5.1.1.  After I spent some time with Ubuntu 7.10, I uncovered some warts there,
chief being that it has gcc 4.1.3 installed. Now Knoppix has 4.2.3 installed, so what is the word on the latest release?  I searched online, and actually Knoppix is right at the bleeding edge in that category, so my interpretation of why Wine failed to compile from the source code was incorrect.

So I decided to reinstall Knoppix 5.1.1 on another partition, only I opt go go with the version I found online that has OpenVZ in the build.  First I had interference from my Canon IP6000D printer, which was still powered on.  It seems the smart card technology used with that printer can hose up my PC, causing the keyboard and mouse to lock up, and delaying the reboot process.  I finally remembered to shut the printer down, and went on from there.

But after loading Knoppix with OpenVZ, I found that I could not convert it to a hdd install.  At least not with the methods I was familiar with.  So I booted again using the Knoppix 5.1.1 release.  I would worry about OpenVZ later.

I used BootPart to try and add the new boot partition to Boot.ini, and that seemed to work, but during the reboot it tried to reboot to the NTFS partition that I have on the same drive.  Being tired and not thinking it through entirely, I decided to change the file system that Knoppix had selected so that it would use est3, which had worked with the first linux partition.  This turned out to be a bit tricky, as if you pick the Knoppix image as on CD, it wants to default the file system.  I finally set it up that way, but then did a partial reconfig to the point where I could redesignate the file system, then used Previous to back up to where I could then go ahead and install.  It worked fine.

But the same problem persisted with BootPart, and in the process of typing this, I think I know why.  Since I elected to use NTLDR to manage my boot efforts, I am confined to what Microsoft supports.  And Microsoft does not support any file systems but its own.  So it cannot really recognize the way I've formatted the additional partitions on the hard drive, except the NTFS one.  That gives you two choices:  Boot from the first partition, which is right at the start of the drive, which NTLDR can access, or boot from a Microsoft compatable partition which does not have to be the first partition on the drive.

So I can either boot from a floppy in order to get to a "foreign" partition, or replace NTLDR with GRUB, which is a good bit smarter.  But before I mess with my boot process, I intend to reimage my whole system to a backup so that I reduce the risk of losing anything on my PC.

There are a couple of specific reasons why I came back to Knoppix rather than move on to another distribution.  First, in comparing it to Ubuntu, I think that Knoppix got it right-er in some respects, although Ubunty admittedly has other strengths to counter with.  Second, with Knoppix 5.2 looming on the horizon, I could afford to wait a bit and see what enhancements it brings. but go ahead and put the current version back on to get familiarized with it and know what to look for next.

Donald Darden

Sometimes you read something, and it seems to mean one thing.  You leave it for a time and come back to it and read it again, and it might seem to mean something different.

As I said before, I was unable to update Wine because I could not find a package intended for Knoppix - I was judging by the different packages being set up for Ubuntu, Suse, Red Hat, and other distributions.

But in reading a post on another thread, I was reminded that Knoppix reverts to a Debian Distro when it is installed to a hard drive.  Actually, you have several options, and the one I chose was to keep the Knoppix file structure (and appearance for the most part).

But it suddenly occurred to me that if Knoppix is really Debian at its heart, then perhaps the Wine package intended for Debian would work on it.  So I folloed the instructions at www.winehq.com for adding that site as an APT source, did the added step for the Debian package (not intended for 64 bits), and used the following command in a terminal window to attempt to get it:

sudo apt-get ugrade wine

And that did it.  It took awhile, because there is a lot involved, but it worked fine.  I also used this command as well:

sudo apt-get update

just to make sure everything is current.  Now I feel that I have the latest and greatest stuff for Knoppix as well as for Ubuntu.  I have a real basis for comparing the two distributions and different aspects of each.  I repeated some of the stuff I discussed before, but I won't waste your time and mine by repeating all that again.

----------------------------------------- Later -----------------------------------------------------
Nope.  Turns out I was wrong.  It looked like it did the update, but I checked again today, and Wine is still at 0.9.12,  So what does it take to get up to 0.9.48 or whatever is the latest?  What is keeping me from being able to get away from the version that came one the Live CD?  I wish I had an answer.  This is becoming a bit frustrating, and if I can;t find an answer, then how about the average joe who knows a lot less than I do about PCs in general?

------------------------------------------- Still Later ----------------------------------------------
Well, sometimes all you can do is start over.  So I went to www.winehq.com and downloaded the source archive for Wine 0.9.48.  Then I used ark to extract it to a new temporary folder.  I went ahead and set the option for ark to open .bz2 files automatically.  Then I positioned into the temporary directory and entered the terminal mode, and used su to make myself the super user,  I again tried ./configure to start the build process.  This time the errors I got were that I did not have flex and did not have bison.  So I used apt-get install to install both.  This time it worked.  I was then told to use make depend && make, which I did.  The compile went on for a long time, and finally finished.  According to the User Guide, I then used make install.  And that ran to completion as well.  And so I did another wine --version, and this time I was told that I now have version 0.9.48 installed.  So FINALLY it's done!

Donald Darden

As I mentioned under the Ubuntu thread, I was bothered by the lack of a way to open the tray doors on the CDRW and DVD drives in my PC.  You can do this manually by opening a terminal console and using the eject command, followed by the device name as found under /medai.  However, I was not entirely happy with this as a solution.

So after I reinstalled Knoppix, I checked and found a similar problem with its desktop.  But in exploring further, I right-clicked on the desktop itself, and looked at the options presented at that point.  Under Create New, I found you could create a link to a device, which I opt to do.  In the next menu, I clicked on the Device tab, then searched for the CDRW drive and set that.  Now I could use this link to eject, that is, cause the door to open on the top drive.  I repeated these steps to link to the DVD drive, and now I can use it to eject the tray on the bottom drive as well.  Problem solved.  i also found I could enable the top toolbar for the desktop, so I did that as well.