• Welcome to Jose's Read Only Forum 2023.

Knoppix 5.1 DVD Now Installed

Started by Donald Darden, December 04, 2007, 05:02:47 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Donald Darden

I have new drives in my PC, upgrading from 280 GB to 480 GB total.  Windows was no problem reinstalling from a backup image, but True Image failed to restore properly into resized partitions.  Not sure if problem was with True Image in adjusting file structures, or whether different drive geometry confused Linux itself.  Decided no harm in just reinstalling the Linux distributions of choice from scratch.

Downloaded and reburned the Live DVD version of Knoppix 5.1.  Decided to go whole hog this time, and skip the Live CD version.  I have a CD-RW and a DVD-ROM/CDRW drive in my PC.   Both are suspect for data reliability right now, and I used an external DVD-RW drive to burn the DVD disk.  I could not find any way to get this HP Desktop to boot via the USB interface - it only looks for a USB-FDD or a USB-ZIP drive (shows you how dated the BIOS set is).  But I accidently discovered that I could initiate the bootup from the LiveCD for Knoppix 5.1.1, and with the external DVD/RW plugged in and the Knoppix 5.1 DVD disk in it, the install process automatically switched over to the DVD after the startup process identified all drives.  Pretty neat, and my present install is from the entire DVD.

I did the same thing as I have before, which is set up the install to be the recommmended Debian (default) method so that I could specify est3 file format for the designated partition, fill in the other requested info, then initiate the installation step again to the point of selecting the Knoppix CD format, then backing out again.  In this manner I could cause the system to use the est3 file format, which Partition Manager and True Image both recognize, yet still get the KDE structure and menus that Knoppix is noted for.

One of the icons on the toolbar is called IceWeasel, which is an open source clone of FireFox.  I read somewhere that they are going to rename this to IceCat.
The thing about IceWeasel/IceCat is that it thinks its FireFox, but it has a distinct problem with font size control.  Every time I follow a link to a new page on the web, I have to either upsize or downsize the text.  You also have another icon therre called Kongueror, which is sort of a mix of what IE and Windows Explorer are under Windows.  I tried it, but it is not really to my taste.  And since this is Linux, Internet Explorer is not an option (something to be grateful for).

There is an alternative, which is Opera.  Yes, there is a Linux version.  In using FireFox under Windows to download some of the really large .ISO files that these Linux distributions come on, I discovered a disconcerting habit of FireFox to just freeze up during the download.  There is some sort of timing issue involved that happens with some download sites, and while the file is still downloading, you cannot really do anything via the keyboard or mouse, other than close FireFox.
When you open it again, it wants to know if  you want to resume the last session, and if you say yes, it will again freeze up.  It's only after the file download is complete that normal use returns.

But guess what:  Opera does not have this problem, and handles file transfers in a separate process.  So right now I am using the newly installed Opera for Linux and going to see if it works better for me.  So far I have no complaints.

Two things I did after reinstalling Knoppix was to use a terminal window and typed in apt-get update, let that finish, then typed in apt-get upgrade.  The upgrade process took about two hours to complete over a high speed internet connection.  Don't foget about using su or sudo -s to get root access when needed.  Oh, by the way, even though you thought you set a user name and password during the install, and the root administrator password,
the hack way above to ensure you get est3 file structures but keep the neat things about Knoppix intact will effectively wipe that out.  You have root priveleges, no account was set up under the name you gave, and no passwords got registered.  You will need to use passwd root in a terminal window to allow you to set the root & su password to something you can use later.

I feel like I am starting to get back on track here.  Tomorrow I have to work on a friend's daughter's PC, so I may not be back right away.